Tuesday, October 18, 2011

Prusa Mendel Reprap: Calibration Step Four


Test cubes. So many test cubes.

Now that you've had your glorious moment with the first print on your printer, it's time to get down to the business of making your prints spectacular. That process begins with a download from Thingiverse. Spacexula's calibration objects are the standby of all RepRappers getting their machines tuned and settings set. The page for the calibration set is quite informative, but really the big deal is printing the 20mm x 20mm x 10mm cube. You'll see a lot of this object coming off the printer.

So, download the set and print the first one of many cubes. When it's printed one of the first things to check are the dimensions. You calibrated the steps_per_unit in firmware earlier, but now is the real first practical test. Get some calipers and measure the width, depth, and height. Go back to prusajr's calculator and make adjustments to the firmware settings. Remember that the line width will throw off the measurement with the calipers by one full line width. So, whether you print 20mm wide or 100mm, an accurate print will measure one line width too wide. Subtract that width from your measurement for the calculator. If you have a .35 nozzle that value is somewhere in the neighborhood of .54mm.

Print the cube repeatedly, measuring and adjusting the x, y and z firmware settings until you home in on the precision you expect. Don't overdo it, though--it can only be just so precise.

Calibration Step Four: Understanding Skeinforge

The good news is that there are only a few really important settings. The even better news in my opinion is that with Skeinforge there are lots of things you can customize and fine tune. There is a program based on Skeinforge called SFact which claims to be simple to use and simple to calibrate. It's not to my taste. Skeinfoge can be a little intimidating at first, but you can get the hang of it quickly if you try. Take it from one beginner to another.

The essence of the following settings has to do with calibrating the machine's flow rate. How much and how fast should the plastic flow out of the nozzle. How fast should the machine move relative to the flow of plastic out of the nozzle? Getting these answers right is the difference between good prints and bad.

A Few Important Settings

Line height and width over thickness ratio (on the Carve tab), filament width and packing density (on the Dimension tab), infill ratio and shells (on the Fill tab), and the feed rate and flow rate (on the Speed tab). With the starter profile you got in Calibration Step Two, you should have some decent defaults and the test cubes shouldn't be too much of a mess.

Dimension

The first stop for Skeinforge is the dimension tab, and there your destination is the filament diameter field. It's important to measure the filament you are using at several places along a 100mm length, and in several angles. Rotate the calipers around the filament. Take down all the measurements and average them. The packing density should be 1 for PLA, and .85 for ABS. Packing density accounts for the stretching that occurs when the filament passes through the pinched wheel extruder. ABS is softer than PLA and stretches more, so it is a bit less "densely packed"than PLA.

Carve

Carve is a very important tab. Line height and width over thickness (often said as w/t) work hand in hand and can greatly affect the quality of the prints. In the calibration set from Spacexula there is a thin wall model whose purpose is to fine tune these two settings. The line height is supposed to be around 80% of the diameter of the nozzle. For a .25mm nozzle, for instance, the ideal line height setting is .2, which is exactly what I'm using to print at after a lot of experimentation. Width over thickness is the setting that tells the machine how much wider the line should be relative to it's height. A perfectly round extrusion profile wouldn't put much of the surface area in contact with the lines above or below, so a somewhat flat extrusion profile is better. Typically a good setting is somewhere between 1.5 and 1.9.

Speed

One issue you might notice while printing test cubes is that maybe the filament gets jammed, or sometimes the extrusion kind of delaminates (doesn't stick down) and bunches up around the nozzle while doing solid layers, or you have trouble walking that fine line between motors skipping steps and having the power turned up so high your motors fry. These can all be symptoms of too high a speed. You will want to print as fast as you can get away with, but which doesn't cause these or other problems. Really the speed you can achieve depends on your motors. With my motors (and nozzle -- they're related) I haven't been able to print reliably higher than 40mm/s. The feed rate and flow rate must be the same number. They are different fields, from what I understand, because Skeinforge used to calculate flow rates differently. I could be wrong, but that's what the best expert on the IRC channel is saying, and I've been able to get good, quality prints by sticking to his advice.

Later, when you get some experience printing, you'll want to come back to the speed tab to work with the settings for bridging prusa parts, be sure to try the quick bridging calibration piece on Thingiverse.

Fill

Lastly, there's fill. Of course, the fill settings determine how the interior of the model is supported. The infill solidity ratio is the key setting, and can be anything from 100% (1.0) to 0% (hallow). PrusaJr says he prints RepRap machine parts with a 20% (0.2) fill. I feel more comfortable printing them at 30% or 35%. For small parts, especially gears, I often use 100% fill.

Also, you can choose what kind of fill pattern you want in Skeinforge, a notable feature not available in SFact. I heard an engineer on the IRC channel say that with the hex fill pattern you can achieve 30% greater strength with the same amount of fill as line fill patterns. I like to use hex, personally, and I don't find it takes very much longer than line fill patterns to print. Besides, it looks cool!

Once you get all of the previously mentioned settings dialed in, you might want to come back to the fill tab and take a look at the oft unappreciated grid extra overlap setting. Changing this value will adjust the distance between parallel lines of solid layer fills. If you notice that the top layer of your print has gaps between the lines, you'll want to increase this a bit.

Done

That's Skeinforge in essence. From here you can do like I did and go to the Skeinforge manual and go through each setting one by one. A lot of the things you just won't tough. Regardless, when you get done with Skeinforge there's one last thing you can do to get your machine set up for happy printing.

Next up: Calibration part five: Bookends

10 comments:

Miguel Sánchez said...

Thanks a lot Hans for your detailed calibration explanations.

I've got just ok first prints from RepSnapper and i've done some firmware calibration with it. I later have installed Pronterface and SF41 with the profiles you mention in your blog. My Prusa has a 5mm nozzle and it looks like my sample prints are "burying" the nozzle of the hot-end into the recently extruded plastic of the infill of the part. I've checked that my filament width is correct in the configuration (3mm) and that the layer height is 0.4 (I guess it is ok for 0.5 mm nozzle).

Any clue?

kwixson said...

If the nozzle isn't moving up (watch the leadscrews at the end of a fill) then your model (STL) is probably below the Z plane. Open the stl in Netfabb Studio Basic to be sure it's moved to the point of origin and then export it from there. If you're using a renosis profile it's unlikely that SF41 is configured so that it would drag the nozzle through the same layer. It sounds like your settings are right, just your model might be off. Let me know if that helped.

Miguel Sánchez said...

I was using the 10 mm sample cube STL from Reprap wiki. I'd be surprised it is not sitting on Z plane as it is suposed to be used for calibration but I have not yet tested it. I'm away from my prusa now though.

I was not meaning that my nozzle is going down but it is going up not enough on each layer, so it pours an ok layer and then it does not go up enough so next fill layer is almost at the same height as the previous one.

RepSnapper printed ok (buy low quality) so I guess hardware is kind of working ok.

Thanks.

kwixson said...

You should get on the #reprap IRC channel. There are lots of people who can help you out, and in real time, too. I could continue to guess, but someone there might know better and be able to help you out right away.

Miguel Sánchez said...

I've repeated the process with similar results. STL is located starting at Z=0. What I can see is that the flow is too high, so the hot-end gets buried in plastic quickly. Reducing (a lot, to 8) the Flow Rate setting in Speed helped quite a lot. Now I am printing from a Linux host and my USB port gets disconnected in the middle of the print, not fun at all. I'll try the IRC. Thanks.

Anonymous said...

I just had my first real print after following this. Thank you so much!

You should really think about putting it on the RepRap wiki. There isn't any single document or page to look at after you go through the visual assembly instructions, and for noobs it's a bit hard to know what to do other than fire up pronterface and hit print (which resulted in near disaster for me). This set of posts is really clear and well written. Thanks again!

ambiguousphoton said...

Hi there,
I am on a mac and downloaded the latest version of pronterface and put skeinforge v41 as a folder in the pronterface folder. The weird thing I run into now is that the carve settings have the width and height parameters missing! Does anyone know why this would be? I had these settings when I was using a newer version of sfact but I backed up all that stuff to install v41 of skeinforge.

kwixson said...

@ambiguousphoton I suspect it might have something to do with the application data in your user directory. Use Finder's "Go to Folders" feature to go to /Users/username/.skeinforge

SFACT is still Skeinforge, and it will create a profile there. This is incompatible with other versions of Skeinforge. If you erase the entire .skeinforge folder from your user directory and then start up SF41 again, it will create a new profile of the appropriate version.

Hopefully that will straighten out your problem.

kwixson said...

/*
Damn delete link is too close to the publish link. Here's the comment I inadvertently deleted.
*/

Hi again,
Thank you so much for the response but unfortunately it didn't seem to work. I can delete the ~/.skeinforge folder (and every other instance of skeinforge I can find other than the main directory) and then when I run SF41 I can see that it creates a ~/.skeinforge directory as well as settings for extrusion, milling, cutting, general settings etc. When I go to carve though the first line there is the "add layer template to SVG" then "infill in direction of bridge". This is without even importing the settings from the website you recommended, but simply downloading the official SF41 and running it by itself.
Thanks again!

Anonymous said...

Brilliant! Thanks ever so much for your help. Finally getting somewhere.
Danny